Config file 39etcportagepackage keywords39 needs updating

:) https://github.com/lvming/gentoo-overlay/blob/master/net-misc/multiget/multiget-1.2.0.ebuild These are the packages that would be merged, in order: Calculating dependencies... [ebuild N *] net-misc/multiget-2.0_alpha::jorgicio 320 Ki B Total: 1 package (1 new), Size of downloads: 320 Ki B The following keyword changes are necessary to proceed: (see "package.accept_keywords" in the portage(5) man page for more details) =net-misc/multiget-2.0_alpha ** NOTE: The --autounmask-keep-masks option will prevent emerge from creating package.unmask or ** keyword changes.

config file 39etcportagepackage keywords39 needs updating-47config file 39etcportagepackage keywords39 needs updating-38config file 39etcportagepackage keywords39 needs updating-28

So, I have stumbled over a page here ,which basically suggest that the installation was problematic. One of the following packages is required to complete your request: - dev-lang/php-5.3.9::gentoo (Change USE: pdo) (dependency required by "www-apps/drupal-7.12" [ebuild]) (dependency required by "drupal" [argument]) sudo emerge -av drupal These are the packages that would be merged, in order: Calculating dependencies... emerge: there are no ebuilds built with USE flags to satisfy "=dev-lang/php-5.3*[apache2]". One of the following packages is required to complete your request: - dev-lang/php-5.3.9::gentoo (Change USE: apache2) (dependency required by "virtual/httpd-php-5.3" [ebuild]) (dependency required by "www-apps/drupal-7.12" [ebuild]) (dependency required by "drupal" [argument]) sudo emerge -av drupal These are the packages that would be merged, in order: Calculating dependencies... [ebuild N ] dev-libs/oniguruma-5.9.2 528 k B [ebuild N ] app-admin/webapp-config-1.50.16-r1 102 k B [ebuild N ] dev-libs/libmcrypt-2.5.8-r2 1,304 k B [ebuild N ] app-admin/eselect-php-0.6.2 2 k B [ebuild N ] media-libs/t1lib-5.1.2 USE="X -doc -static-libs" 1,829 k B [ebuild N ] virtual/httpd-cgi-0 0 k B [ebuild N ] app-text/aspell-0.60.6.1 USE="nls" LINGUAS="-af -be -bg -br -ca -cs -cy -da -de -el -en -eo -es -et -fi -fo -fr -ga -gl -he -hr -is -it -la -lt -nl -no -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -uk -vi" 1,835 k B [ebuild N ] app-dicts/aspell-en-6.0.0 179 k B [ebuild N ] dev-lang/php-5.3.9 USE="apache2 berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json ldap mysql mysqli nls pdo phar posix readline session simplexml spell ssl tokenizer truetype unicode xml zlib -bcmath -calendar -cdb -cgi -cjk -curl -curlwrappers -debug -doc -embed -enchant -firebird -flatfile -fpm -frontbase -ftp -gmp -imap -inifile -intl -iodbc -kerberos -kolab -ldap-sasl -libedit -mhash -mssql -mysqlnd -oci8-instant-client -odbc -pcntl -pic -postgres -qdbm -recode -sharedmem -snmp -soap -sockets -sqlite -sqlite3 -suhosin -sybase-ct -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -zip" 11,438 k B [ebuild N ] virtual/httpd-php-5.3 0 k B [ebuild N ~] www-apps/drupal-7.12 USE="mysql -postgres -sqlite -vhosts" 3,017 k B Total: 11 packages (11 new), Size of downloads: 20,229 k B Would you like to merge these packages?

So I decided to plunge into it to have a crack on it. All ebuilds that could satisfy "drupal" have been masked. One of the following masked packages is required to complete your request: dev-lang/php pdo gd mysql mysqli xml - www-apps/drupal-7.12::gentoo (masked by: ~x86 keyword) - www-apps/drupal-7.10::gentoo (masked by: ~x86 keyword) - www-apps/drupal-6.24::gentoo (masked by: ~x86 keyword) - www-apps/drupal-6.22::gentoo (masked by: ~x86 keyword) - www-apps/drupal-5.23::gentoo (masked by: ~x86 keyword) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. [Yes/No] y On the process to get it into my system I have added it keywords file and made some flags to add with the php .

You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]" have been masked. You must upgrade to a newer version of portage before EAPI masked packages can be installed. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]) required by (dev-python/ssl-fetch-0.3:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/py-1.4.30:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sys-apps/kmod-19:0/0::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_pypy(-)?

For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. (dependency required by "dev-python/requests-2.9.1-r2::gentoo" [ebuild]) (dependency required by "dev-python/ssl-fetch-0.4::gentoo" [ebuild]) (dependency required by "app-portage/layman-2.3.0-r1::gentoo" [ebuild]) (dependency required by "@selected" [set]) (dependency required by "@world" [argument]) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook.

================================================================= * Install completed - success sudo mysql -u root -p Enter password: Welcome to the My SQL monitor. Your My SQL connection id is 1 Server version: 5.1.61-log Gentoo Linux mysql-5.1.61 Copyright (c) 2000, 2011, Oracle and/or its affiliates. Oracle is a registered trademark of Oracle Corporation and/or its affiliates. mysql INSERT INTO user (host, user, password, select_priv, insert_priv, update_priv) VALUES ('Gentoo Linux', 'drupal', PASSWORD('drupal'), 'Y', 'Y', 'Y'); Query OK, 1 row affected, 3 warnings (0.00 sec) mysql sudo emerge -av drush Password: These are the packages that would be merged, in order: Calculating dependencies... sudo emerge -av drush These are the packages that would be merged, in order: Calculating dependencies... [ebuild N ] dev-php/PEAR-PEAR-1.9.3 289 k B [ebuild N ] dev-php/PEAR-Structures_Graph-1.0.4 30 k B [ebuild N ] dev-php/PEAR-Console_Getopt-1.3.1 5 k B [ebuild N ] dev-php/PEAR-Archive_Tar-1.3.7 18 k B [ebuild N ] dev-php/PEAR-XML_Util-1.2.1-r2 18 k B [ebuild N ] dev-php/pear-1.9.3 0 k B [ebuild N ~] app-admin/drush-4.4 USE="-examples" 248 k B Total: 7 packages (7 new), Size of downloads: 605 k B Would you like to merge these packages?

Comments